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Users
= Administer users
= Specify notification methods

Logging and reporting
= View log

= Export lo

= Print yesterday's log

= Email reports to users

Configure your notification and logging options
= Options
= Message Builder

© 2003 MHSoftware



Contacting MH Software

Contacting MH Software

= Contact MH Software at info@mhsoftware.co.uk

= Visit them on the web at mhsoftware.co.uk

= Alternatively you can write to:

MH Software

Whynford Industrial Park
Belbins

Romsey

Hants

UK

SO51 OPE

Back to Main Screen

Back to Contents Page

Introducing LetUknow
What does it do?

LetUknow provides a "peace of mind" method of monitoring your LAN and resources. You can
specify numerous jobs and tests in advance on a "set and forget" basis. LetUknow then runs
these jobs at regular intervals chosen by you. If a test fails, the appropriate individuals are
notified immediately via email, network messaging or printed copy, letting you respond to a
problem before your users start to complain.

E= LetUknow is a "must-have" utility for anyone supporting a range of IT equipment.

Back to Main Screen

Back to Contents Page
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5 LetUKnow
— 3.2

3. Useful Features

LetUknow has been developed for easy use and provides many useful features including:
m Set "ping" tests" for each server, router or other network component on your LAN or WAN
= Supports up to 50 users

= Set free disk space thresholds for all shared drives

m Set checks for maximum size of any folder on the network.

= Check for existence of a specified file on the network

= Check UNC path availability

m All tests executed automatically according to your specified schedule

m Select users to be notified and notification methods to be employed

= View log of all completed tests or just those that have passed or failed
m Export log as a CSV file to your spreadsheet or database application

m Select specific tests to run with a simply mouse click.

m Configure Reports and email them to selected users.

Back to Main Screen

Back to Contents Page

4 Main Screen

LetUknow has been developed for easy use and all main functions are readily accessed from the
main user screen.

Click on the image for more details.
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Main Screen 6
=101 ]

IEiIe Tools Yiew Help

I | Hew | Edit 3¢ Delate | L Run &l jobs [ Run selected job | B Users | 1) options | 1\ Message Builder | { Log
Job Mame | Type | Details | Lazt run | I ewt run

) ce test v 09:00
',';"1 Test for master file Today 20:59
-]
Time | Detailz |

O 08/10/2003 08:57:10  LetUknow v2.00 BETA 5.2 started

4 08/10,/2003 03:58:53  Job "Dizk space test" waz successful with 22,718 Mb free zpace. Minimum allowed i 100 Mb

4 08/10/2003 08:59:33  Job "Test for master file' was successiul - File located [C:A\Documents and Settings\Owner\DesktopWIP\MasteriMa. .
e 08/10,/2003 03:59:34  Job "Dizk space test" waz successful with 22,718 Mb free zpace. Minimum allowed iz 100 Mb

|dle ** Mo gelected jobs failed

Back to Contents Page

File Menu

Click on image for more details.

j [l Ins
% Mew duplicate  Chrl+C
& Edit Chrl+E
X Celete el
I Exit Chrb

Back to Main Screen

Back to Contents Page
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7 LetUKnow

4.2

4.3

4.4

View Menu

Click on image for more details.

% Log Chrl+L
ﬂ Yiew lask resulk

Back to Main Screen

Back to Contents Page

Tools Menu

Click on image for more details.

" options Chrl+-0
B lsers el
L L Message Builder

~ Print Yesterdays Log

Back to Main Screen

Back to Contents Page

Help Menu

Click on image for more details.

¢ About
Tip of the daw
Conkents Fl

Back to Main Screen

Back to Contents Page
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Main Screen 8

Main Toolbar

All main functions can be accessed from the main toolbar. Click on the image for more details.

J I tew (2 Edit 3 Delete | U4 Bun all jobs [ Run selected job | 8 Users | ¢y options | 1) Message Builder | {% Log

Back to Main Screen

Back to Contents Page

Jobs
Add ajob

To add a new job, click —t] on the main toolbar or select "New" from the File menu. The Job
Details dialog will be displayed.

Job Details x|

Configure your jobs and select users to receive notifications @
Jab Details | Matification
Job Hame
TE!:E:t for master file | Aocelerate on failure
Job Tupe Fun everny Fun every
|File izt exist "’| |12 . ||hu:-ur$ v| | 13 ”hu:uurs "’|
L) File
File |E:"~Dn:n::uments and SettingzhOwnertDeskiophh/ | Phhd asterbd aster @|
OK&Run || 0K || Cancel

Enter a Job Name and select the Job Type from the drop-down list. Depending on which type of
test you choose, you will be prompted for various data. In the above example, "File must exist"

has been selected and so you are prompted for the location of the file that must exist. Click
to browse for the file. See job types for details of other tests .

Schedule
You can schedule how often your job will run, in hours and minutes. A default Jobs time can be

set from the Options menu. If the Accelerate on failure box is checked, you can choose the new
interval at which the test will be performed.

© 2003 MHSoftware



LetUKnow

5.2

Notification
Click the notification tab to configure notification methods.

When you have entered the required settings you can save the job by clicking OK or can choose
to run it immediately by clicking OK & Run.

Back to Main Screen

Back to Contents Page

Job types

The following tests can be scheduled using LetUknow:

Ping test- enter the IP address/ PC name and the timeout interval for the ping in milliseconds.
File must exist-enter the location of the file.

File must not exist-enter the location of the file.

Check Folder size- enter the location of the folder and the maximum size allowed in Mb.
Check UNC availability-enter UNC location.

Check for low disk space-specify drive and minimum space allowed in Mb.

Check file size-enter file location and maximum size allowed in Mb.

Back to Main Screen

Back to Contents Page
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Jobs 10

5.3  Notification
x|

Configure your jobs and select users to receive notifications @

Job Details :| Matification

[dzer(z] to Matify

John Growler
Steve Fuddle Lhoose users

Trudie England

M atification Frequency

| Ewver fail -

Additional Meszage [Meszage Builder]

| <Mot Entered: -

Play zound notification;

Failed notification sound Successful notification sound

| 2 | &

| OK&Run || oK || Cancel

LetUknow allows you to specify who and when to notify about a test result. Click "Choose users”
to select exactly who will be notified from a list of all configured users. Additional users can
easily be added to the list.

Select when users will be notified by specifying the "Notification Frequency". The options are:

= Every fail
m Every fail, single successful
m Single fail, single successful

An Additional Message can be appended to the standard test result. New messages can be
configured using the Message Builder.

If the Play sound notification box is checked, an audible alert will be played to the selected
users. Click @ to browse for the appropriate WAV files.

E=You can specify the notification methods for individual users from the Users function.

Back to Job details

Back to Main Screen

Back to Contents Page
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11 LetUKnow

— 54

9.5

5.6

5.7

Duplicate a job

To duplicate a job, highlight an existing job and select New Duplicate from the File menu or the
main toolbar. The Job details dialog will be displayed for the highlighted job and you can edit as
required.

ExUse this function as a quick way to create lots of similar jobs.

Back to Main Screen

Back to Contents Page

Edit ajob

To edit a job, highlight an existing job and select Edit from the File menu or main toolbar. The
Job details dialog will be displayed for the highlighted job and you can edit as required.

Back to Main Screen

Back to Contents Page

Delete a job

To delete a job, highlight it and select Delete from the File menu or main toolbar.

Back to Main Screen

Back to Contents Page

Select jobs
Job Hame |

U] Test for master file

Check the box next to your chosen Job to "select it". A job will only be run if it is selected in this
way.

ExUse this function to switch configured jobs "on" and "off" without having to delete them
completely. If a job is required at a later date it can be reactivated with a simple mouse click.

Back to Main Screen

Back to Contents Page
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5.8

5.9

5.10

Jobs

12

Run all jobs

Select Run all jobs from the main toolbar to start all currently selected jobs.

Back to Main Screen

Back to Contents Page

Run selected job

Select Run selected job from the main toolbar to start the job that is currently highlighted.

Back to Main Screen

Back to Contents Page

Successful job

=101l

IEiIe Tools Yiew Help

I | Hew | Edit 3¢ Delate | L Run &l jobs [ Run selected job | B Users | 1) options | 1\ Message Builder | { Log

Job Mame | Type | Details | Lazt run | I ewt run
1 . i T|:||:|.3_|,| 02:53 T|:||:|.3_|,| 09:00
The following file must exist [C:ADocuments an.. Today 08:53 Today 20:59

for & minimum of 100ME an drive

file: File: bzt E izt

Time | Detailz

O 08/10/2003 08:57:10  LetUknow v2.00 BETA 5.2 started

4 08/10,/2003 03:58:53  Job "Dizk space test" waz successful with 22,718 Mb free zpace. Minimum allowed i 100 Mb

4 08/10/2003 08:59:33  Job "Test for master file' was successiul - File located [C:A\Documents and Settings\Owner\DesktopWIP\MasteriMa. .
e 08/10,/2003 03:59:34  Job "Dizk space test" waz successful with 22,718 Mb free zpace. Minimum allowed iz 100 Mb

|dle ** Mo gelected jobs failed

Each time a job runs successfully, the result is displayed in the lower window next to a ¥,

Back to Main Screen

Back to Contents Page
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13 LetUKnow

—5.11 Failedjob

" LetUknow [Running] =1of x|
IEiIe Tools Yiew Help

I | Hew | Edit 3¢ Delate | L Run &l jobs [ Run selected job | B Users | 1) options | 1\ Message Builder | { Log

Job Mame | Type | Details | Lazt run | I ewt run
ce 3 Today 3
ﬂ Fasf for mas... File Mot Faysf Fhea follosing e mest osisf fE5 Foday 8575 Foday T&75
-]
Time | Detailz |T|
4 08/10/2003 09:22:35  Job "Disk space test' was successiul with 22,712 Mb free space. Minimurn allowed iz 100 Mb

e 08/0/2003 0923368 Job "Digk space test" waz successful with 22,712 Mb free zpace. Minimum allowed iz 100 Mb

4 081072003 09:24:368  Job "Disk space test' was successiul with 22,712 Mb free space. Minimurn allowed iz 100 Mb

3£ 081042003 092517 Job "Test for master fle" failed with the follawing information - Unable to find file "C:AD ocuments and SettingshOwnert, .
4w 08/10/2003 032513 Sent On Screen notification via "MET SEMD" ta John Growler

4 08/10/2003 09.25:18  Sent On Screen notification via "NET SEND" to Steve Fuddle

4 081072003 09:25:18  Sent On Screen natification via "MET SEMD" ta Trudie England

[dle \iﬂ SELECTED JOB(S] FAILED .::

If a job fails, the result is displayed in the lower window next to a & . The failed Job Name will
turn red as in the example above and the number of failed jobs will be displayed as below.

'i 1 SELECTED JOB[S] FAILED .::

E=When a failed job is subsequently successful, the Job name will revert to its original font
colour.

Back to Main Screen

Back to Contents Page

© 2003 MHSoftware



Jobs

5.12 View last result

Select View last result from the View Menu or main toolbar to see the last outcome of the
currently highlighted job.

For example:

x

— 29/10/2003 14:23:50
y Job "Test For master file" was successful - File located {C:YDocuments and
SettingstownerDeskiopiMIPMasteriMaster)

Back to Main Screen

Back to Contents Page

14
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Administer users

Select Users from the main toolbar to add, edit, change or delete a user.

Administer Users X|

Add. change and delete users Eﬁ

Jahn Growler
Steve Ruddle
Trudie England

Edit

Delete

Cloze

To add or change the properties of a user, fill in the appropriate details as below.

User Details x|

Set up details of users s&

Hame EitE'-.-'e Ruddle |

PC Mamme ser | SteveR |

Email address [MAF) |steve@uurplace.cu.uk |
Email address (SMTF] | steve@ourplace net |

M atifty Yia [] EMail notification wia MAP
[] EMail natification via SMTP
Metwark, Mezzage
[ Prirker niotific.ation

k. | | Cancel

Select the methods that will be available this user.

EXRemember that you must enter all the information relevant to the chosen notification method.
For example, if you select email (MAPI) you must provide an appropriate email address for this
service.

To delete a user, highlight them in the user list and click Delete.

© 2003 MHSoftware



Administer users

Back to Main Screen

Back to Contents Page

Options

The options menu is accessed from the Tools Menu or the main toolbar and is used to configure
notification and logging preferences. The following tabs are available:

= email MAPI
= email SMTP
® On screen

m jobs/notify

m reports

Back to Main Screen

Back to Contents Page

email MAPI
options x|
@
Configure notification optionz and logging H";E.F':;

EMail MAFI | EMail SMTP | On Soreen | Jobs/Matify | Feports

Usze Email notification [MAPI]

Uzer name | |

Pazzword | | Confirm |

Profile | Microgoft Outlook, |

Subject == |WMPORTANT EMail notification from LetUknow == |

ok, || Cancel |

Check Use Email notification (MAPI) to enable user notification by this method.

Enter the appropriate User name, Password , password confirmation and Profile for this
service.

Enter the Subject. This will be displayed at the top of all notification emails sent to users using
this service.

Back to Main Screen

Back to Contents Page
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17 LetUKnow

— 7.2 email SMTP

options x|
Configure notification options and logging !;-?_;1
-

EMail MAPI [ EMal SMTP | OnSereen | Jobs/Notify | Reports

I1ze Email naotification [SMTF)

SMTP Server ||:": |

From address |LetL|knl:lw@yl:uur|:|:umpan_l,l.c |

Subject

=* [MPORTAMT EMail notification from Letlknow == |

| ok, || Cancel |

Check Use Email notification (SMTP) to enable user natification by this method.
Enter the appropriate Port, SMTP Server and From address for this service.

Enter the Subject. This will be displayed at the top of all notification emails sent to users using
this service.

Back to Main Screen

Back to Contents Page

7.3 on screen

options x|
Configure notification options and logging !;-?_;1
-

EMail M&FI | EMail SMTP | On Soieen | Jobs/Matify | Fieports
(e Ugze Met Send [windows NT)
) Use Send Ta [Navell]

ok, | | Cancel

Check the appropriate box to enable the on screen text messaging service that will be used for
user notification.

© 2003 MHSoftware



7.4

Options 18

Back to Main Screen

Back to Contents Page

jobs/notify
options x|
Configure notification options and logging !1":';;

EMail MAFI | EMail SMTP | On Soreen | Jobs/Matify | Feports

Auta run zelected jobz on startup Drefault jobs time
Default jobz run bype

[] Dizplay natification failures Retain log hiztory for [dayps]

ok, || Cancel |

When Auto run selected jobs on startup is checked, all selected jobs will automatically run on
startup of LetUknow.

Select the Default jobs time in minutes or hours. This will set the default time interval between
executions of the job.

When Delete failed notifications is enabled, all notifications that were not delivered successfully
will be deleted.

When Display notification failures is enabled, notification failures will be displayed in the log.
Select the number of days to retain log history.
Ex1og history can be retain for a maximum of 100 days.

Back to Main Screen

Back to Contents Page
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19 LetUKnow

~— 7.5 reports

Configure notification optionz and logging

&

X

EMail MAFI | EMail SMTP | On Soreen | Jobs/Matify | Fieports

Weekly dizk space

Edit

Delete

II :
[l
(=

ok, || Cancel |
Click "Add" to compile a new report type.
=10 %] =10 %]
Select Jobe and Ugers Lo regol on {1‘;- Select Jobe and Ugers Lo regol on {1‘;-
Hame Hame
|‘-'r'eekl}l dek space | |‘-'r'eekl}l dek space |
Erequency Erequency
|'W'e=kkr- "l |'W'e=kkr- "l
Time of day StaithastFiun Time of day StaithastFiun
15 - 06:10/200% =] |mis - 06:10/200% -
mLIﬂs' mm | Ussts
Dwkopacebest | | Chenga Jobe ‘éﬂ“ﬁﬁ;ﬁe Chenta Lloaie
Trade Englard
[ ok || Coce || hep | [ ok || Coce || hep |

Give the Report a Name, Frequency, time of day and date for the start of next run.

You then need to select all the Jobs and Users that will be included in the Report by clicking
"Choose Jobs" or "Choose Users" as appropriate. The following dialogs will be displayed:

© 2003 MHSoftware



* Select Jobs

Tick all jobs

=10l x|

o

Bl select users x|

Tick all users required

Options

8

LT est for master file

[] Digk space test
[ ping

ak

| | LCancel

[] Jahn Growler
[] Steve Ruddle
[ Trudie England

ak

|| LCancel |

20

Simply tick the required elements and they will be included in the Report. Reports will be emailed
to the appropriate users by their selected email method.

Back to Main Screen

Back to Contents Page
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Message builder

The message builder lets you customise on screen and email messages . Select Message Builder
from the Tools menu or main toolbar.

Bl

Customise on screen and email messages 1

Driginal waord(z]

| File lozated

whard(z]

"MET SEMD" —
"Send Ta" —
Cannot ping host -
Error zending Email Edit

failed with the following infarmation
_ Delete

File not found

free space. Minimum allowed is
has been detected. Minimum allowed iz
has been found

host regponded

i gize.

£

Jaob

Low digk zpace

b @sirnum file zize allowed iz

b awirmurn folder zize allowed iz
Perfarming notifications

Printed notification Far

Running

Running job

Sent Emaill natification ko

Sent On Screen notification via

The -

[
[

Cloze

Click Add to create a new message.

Word Properties x|

Original word(s]

| <Mot Entered: |

Actual word(z]

Bestare || ok || Cancel |

Write your new message and click OK to save. New messages will be available for selection
when you configure the notification for a new job.

© 2003 MHSoftware



Message builder 22

E=1f you edit an existing message you can revert to the original text by clicking Restore.

Back to Main Screen

Back to Contents Page

Log
Select Log from the View menu or main toolbar to view log details.
*% Log Information - O] =|
Yiew and Save information about all or selected jobs f&
Filter on job |<¢'1'~IIJ0|:|S> v| Filter on entries |<.-'1'~||Entries> - |/_|
Fram 271042003 »| 1o |27N0/2003 -|
Time | Detailz |

27M10/200215:07.08  Letknow «2.00 BETA 5.2 started

2702003 15:08:11  Job "Test far master file' was successful - File located [C:ADocuments and SettingzhOwnersD .
2702003155735 Job "Test for master file' waz succeszsful - File located [C:A\Documents and SettingshOwnertD. ..
27042003 155749 LetUknow 2,00 BETA 5.2 shutting down

27410/20023 16:09:20 Letknow w200 BETA 5.2 started

| Entries = 5 Wy

You can specify the exact dates that you are interested in and filter the information according to
Job name and log entry. The possible log entries are:

= failed job

m successful job

= successful notification
= failed notification

= internal error

s startup/shutdown

The log can be exported.

Back to Main Screen

Back to Contents Page
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23 LetUKnow

— 9.1 printyesterday's log

Select Print yesterday's log from the Tools menu to print a copy of the log from the preceding
day.

Back to Main Screen

Back to Contents Page

9.2 Exportlog
Click CSV at the bottom of the log viewer to export the details in CSV file format.

Back to Main Screen

Back to Contents Page

10 Systemtray

LetUknow can be minimised to sit in your system tray, saving you room on your screen.

« BEED g 09:23

The system tray context menu looks like this.

j e Ins
Li‘] Run all jobs  Ckrl+3

1 options Chrl4+0

L} Message Builder

S Log Chrl+L

[ Exit Chrh

Click on image for more details.

Back to Main Screen

Back to Contents Page
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12

13

14

Context menu

Context menu

A Context Menu refers to additional functions can be access by right-clicking the mouse at
certain points on the screen.

Back to Main Screen

Back to Contents Page

About

Displays the version number of LetUknow that you are running.

Back to Main Screen

Back to Contents Page

Tip of the day

Shows the current "Tip of the Day". Check box to view a tip at startup.

Back to Main Screen

Back to Contents Page

Exit
Select Exit from the File Menu to exit LetUknow.

Back to Main Screen

Back to Contents Page

24
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